Deploying the new SRM 8.2 appliance

VMware have been moving away from Windows installs of vCenter Server and 6.7 is going to be the last Windows version (hurrah!). SRM was next in their sights and with the release of 8.2 we can say goodbye to the Windows version and associated license and issues it came with (slow start up for one). Linux environments who use SRM, or previously hadn’t and had discounted it based on having to use Windows Server will be pleased by this news.

This post is going to talk about how we deploy it and connect it to your vSphere Replication Appliances. It assumes that these are already installed and configured into your vCenter environment.

First job is to download the appliance from here on VMware’s download page. While it’s downloading, it’s a good idea to add some static host entries onto your DNS server for the SRM servers.

Once downloaded, mount the ISO onto your computer and log into the vSphere client and deploy an OFV template onto your cluster.

Head to the mounted ISO drive and then the bin folder. Select all files within this folder. Why it hasn’t been packaged as a proper OVF is a mystery to me.

Now we follow the familiar OFV wizard. Give the new VM a name and place it on the appropriate datacenter.

Now choose the cluster for the VM to reside on. If you do not have DRS then you need to select an individual host.

The OFV package will now be imported which will expose the particular OFV options. First of is the details of the package.

Next up we have the familiar license agreement.

Now we choose whether the appliance has 2 or 4 vCPU. Since I am installing it on my homelab and I don’t expect to be replicating a large number of VMs I am choosing 2. For larger environments choose 4. I actually couldn’t find any information in the release notes to suggest when 4 should be used, if someone does see this somewhere then please drop me an email.

Now we choose our datastore. I try and keep as much as I can on my vSAN datastore as it is all flash and my QNAP is still spinning rust.

Next up we configure the networking options. I am running everything on a DVS Port Group tagged VLAN 2 for all my management VMs. I also use static IP addressing which I would recommend for this appliance.

On the next screen we set the networking and various passwords and security options. For production use I would disable SSH and only enable it if you are troubleshooting or asked to by VMware support if you have a ticket open. Since this is a homelab, I am going to enable it.

There are three users which require a password; root, admin and the database user. These passwords should all be complex and different from each other, plus documented in Keypass or similar. Ensure all of your network settings are correct as you will have to redeploy if not – or delve into the depths of Photon OS to fix!

Review the final screen and press finish if you are sure all the details are correct. The SRM appliance will now be deployed.

When the VM has deployed, it will be in a powered off state. Deploying the VM will take longer than it will to start up as the appliance is lightning quick and should start up in under 30 seconds. Much better than previous iterations of SRM on Windows where it can take quite a long time for all services to start!

Head to https://<srm host name or ip address>:5480 and log in with the admin account you configured during the deployment process.

The UI is extremely clean simple, similar to the new VAMI interface of the vCenter Appliance. The next step is to configure the appliance, by pressing the configure appliance button which you can’t miss.

If you have an embedded PSC appliance, which you should be using as external PCSs are being deprecated, enter the vCenter host name and SSO username/password.

You will get a certificate warning, connect anyway. Then choose your vCenter server from the list. Again, you will get a certificate warning so accept it as before.

Enter the site name. Since SRM is usually used to replicate between datacenters, the geographical location is a suitable choice. In the majority of cases, the default Extension ID can be used.

Once complete, proceed with the setup. This will now register extensions with the vCenter server. You may have to log out and back in again to the vSphere Client before the plugin shows under the menu.

Now repeat this process for your second site, ensuring that it is registered against the second vCenter server in the final steps. What I have noticed is that if you use a Chromium based browser and when you come to configure the second appliance, something odd happens with the auto complete and even though you select the second appliance, it still talks to the first. If you get the following error message:

A specified parameter was not correct: connection.thumbprint

To get around this, use an incognito window or a different browser. I’ve tried this both with Chrome and Brave (a Chrome based privacy based browser) with the same result. Edge however worked wonders. Read more about the issue here.

Once done, if you head to Site Recovery within the vSphere client, everything should be green. If you are going to be using Storage Replication Adapters to leverage storage based replication, there is no need to configure a VRM appliance so that will not show. Since I do not have replicating storage appliances at home (who does?), I am using VRM and I cannot show you how to configure the storage using SRAs. I will do a guide on installing the VRM and how to set it up soon.

From here on we can configure SRM how we wish. I will also cover this in a future blog post.

Thanks for reading. Please leave a comment or send me a message if you have any comments or questions.

Leave a Reply

Your email address will not be published. Required fields are marked *